Customers view not retrieving customers
Incident Report for Twice
Resolved
The problem has been resolved.
Posted Feb 01, 2023 - 16:21 UTC
Identified
Our engineers noticed an issue when listing the customers from the merchant admin interface. Our team is currently working to fix the issue.

There is no workaround available, an update regarding the fixing will be posted in our status page within one hour.
Posted Feb 01, 2023 - 15:29 UTC
This incident affected: Store Admin.