Increased network latency
Incident Report for Twice
Resolved
This incident has been resolved.
Posted Mar 31, 2023 - 06:15 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 30, 2023 - 14:17 UTC
Monitoring
All Rentle systems should work normally. We keep on monitoring the situation.
Posted Mar 30, 2023 - 12:08 UTC
Update
We have worked on mitigating the issue and most parts of the Rentle system should work normally. We will keep on monitoring and mitigating the still-affected parts of the system.
Posted Mar 30, 2023 - 10:10 UTC
Identified
We are seeing increased network latencies across Rentle systems. There might be increased load times across Rentle systems, and some actions may fail. This is due to issues in the global Google Cloud networking, which Rentle is utilizing in their systems. We are working to mitigate the issues and report once the issues have been resolved.

More detailed information about the underlying issue: https://status.cloud.google.com/incidents/nieR2aLyg1rwFKq1aWZU#2c2sBHWU84yPDJ8y1ar4
Posted Mar 30, 2023 - 06:11 UTC
This incident affected: Online stores, Store Admin, and Infrastructure.