Payment Refunds Not Working

Incident Report for Twice

Resolved

This incident has been resolved.
Posted Mar 10, 2023 - 07:41 UTC

Monitoring

A fix is being released and all refunds should be back to normal by 21:30. Our team and our payments partner team are monitoring. After the fix all transactions can be normally refunded.
Posted Mar 09, 2023 - 18:50 UTC

Update

We identified with our payment provider possible causes and our teams are continuing investigating the issue.
Posted Mar 09, 2023 - 15:20 UTC

Investigating

Customers reported repeated errors when trying to refund purchases made using Rentle Payments, our engineers are currently investigating and new information will be updated in our status page.
Posted Mar 09, 2023 - 12:25 UTC
This incident affected: Store Admin.