Rentle plan upgrades not working
Incident Report for Twice
Resolved
We identified that the issue was caused by failures in the deployment of new payment features and it has now been resolved. If the problem persists, it should be easily resolved by refreshing the page.
Posted Jun 27, 2023 - 08:58 UTC
Investigating
Our engineers identified that plan upgrades are currently not working. The issue started approximately 10 AM CET and the causes are under investigation by the team. This issue does not impact the product.
Posted Jun 27, 2023 - 08:26 UTC
This incident affected: Store Admin.