Email Delivery Issues

Incident Report for Twice

Resolved

Incident is resolved. If you still encounter any email issues, please contact support.
Posted Sep 10, 2025 - 10:00 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 09, 2025 - 12:00 UTC

Update

All emails should be working normally. We keep on monitoring the situation.
Posted Sep 09, 2025 - 10:55 UTC

Monitoring

Most new emails, including order confirmations, are now being processed and delivered again. We are continuing to work on restoring full functionality so that all emails are sent without disruption.
Posted Sep 09, 2025 - 07:25 UTC

Identified

Since September 8th, 5:00 PM EEST, our system has been experiencing an issue where emails (such as order confirmations and notifications) are not being processed or delivered. Our team is actively investigating and working on a fix.
Posted Sep 08, 2025 - 17:00 UTC
This incident affected: Online stores and Store Admin.