Missing Merchant Invoices
Incident Report for Twice
Resolved
The incident has been resolved and failed invoices are being regenerated. If the admin interface still fails to retrieve invoices, contact support.
Posted Feb 17, 2023 - 14:41 UTC
Identified
The issue has been identified and our team is working on a fix.
Posted Feb 17, 2023 - 13:02 UTC
Investigating
It has been identified by our team that the system of automated invoicing had issues with producing printable versions of the invoices. The issue started at 2 AM EET on the 15th of February. No workaround available, invoices will be backfilled. Invoice charges have not been affected, the incident impacted only the invoice document creation.
Posted Feb 17, 2023 - 06:55 UTC
This incident affected: Store Admin.