Manual order creation and Booking Links failing
Incident Report for Twice
Resolved
This incident has been resolved.
Posted Jun 29, 2023 - 14:57 UTC
Identified
At 17 our engineers identified that some customers are unable to create manual orders or send booking links. The cause has been identified and a solution will be deployed shortly.
Posted Jun 29, 2023 - 14:41 UTC
This incident affected: Store Admin.